everywhere-config/configuration.nix
System administrator 9869100b8e Attempt boot fixes
2025-05-15 08:15:06 +00:00

35 lines
791 B
Nix

{
modulesPath,
lib,
pkgs,
...
}:
{
imports = [
(modulesPath + "/installer/scan/not-detected.nix")
./disk-config.nix
];
boot.loader.systemd-boot.enable = false;
boot.loader.grub = {
enable = true;
# no need to set devices, disko will add all devices that have a EF02 partition to the list already
devices = [ "/dev/nvme0n1" ];
# device = "/dev/nvme0n1";
efiSupport = false;
# efiInstallAsRemovable = true;
};
services.openssh.enable = true;
environment.systemPackages = map lib.lowPrio [
pkgs.curl
pkgs.gitMinimal
];
users.users.root.openssh.authorizedKeys.keys = [
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIHDuOIycRP7Ney136ro/doWj1kttJUqmbGz6OC2nia09 michael.huebner@ptspaper.de"
];
system.stateVersion = "24.05";
}